Jump to content

mightygrinch

Members
  • Content count

    1
  • Joined

  • Last visited

  • Feedback

    N/A

About mightygrinch

  • Rank
    Thrift Store 7"
  1. Hello everyone, I don't know if this is the right place for this, but I really need help with my turntable and this is one of the few places that seems like it has an active forum. The model of turntable that I'm using is a QFO LE which is a turntable with a built-in mixer; I've never had any issues with it, but I was away for a couple of months and when I came back I noticed that it wasn't playing records normally. It seemed like the record was wavy (pitch was out of wack for no reason, going from fast to slow and then back to fast repeatedly) and every record I was playing was sounding drunk for some reason. I took it apart and I noticed that the motor is making a -stuck- noise but it still manages to push forward. It keeps itself in place like it's shaking and when I turn the motor off it's still shaking. I have nowhere to go with this issue because vestax has been discontinued and no one has ever posted about QFO problems other than the paint being scratched off. I tried looking up PDX2000s noise problems but theirs is just the motor being dead completely. I've also taken apart under the turntable to see on the other side but there's too much circuitry for me to do anything or to see if anything is stuck there. It doesn't seem like there is, it seems to me like it needs grease or something but I'm not sure how one goes about greasing up a turntable. If anyone could give me any info it would be very much appreciated. Thanks in advance.
×