Jump to content

Need help with automatic direct drive arm on Technics SL-3300.


Recommended Posts

I have a Technics SL-3300 that has a direct drive automatic arm. So you hit the start knob to the right, and it does it's thing - automatically moves the arm, and lowers it onto the record. Here's where the problem comes in. When the needle hits the record, it maybe stays there for a second or two before lifting back up and going back. Is there any way to either fix this or disable it and using it as a manual arm?

 

I would love to be able to do this myself rather than have to take it to a shop and do parts and labor on it.

 

I can provide a video if needed.

 

Thanks for any help.

 

Link to post
Share on other sites

I had a turntable where this happened. It never completed the end cycle after it reached the middle. I took the album off right as the sequence was engaging and it became stuck in that. I moved the arm manually towards the center and let the gears reset and voila! Under the platter should be the gears as well, but I'm not horrendously familiar with direct drive, although that mechanism shouldn't differ terribly.

Link to post
Share on other sites

I had a turntable where this happened. It never completed the end cycle after it reached the middle. I took the album off right as the sequence was engaging and it became stuck in that. I moved the arm manually towards the center and let the gears reset and voila! Under the platter should be the gears as well, but I'm not horrendously familiar with direct drive, although that mechanism shouldn't differ terribly.

 

The thing is that it never even gets the chance to reach the middle. It has a mind of its own. As soon as it has power the platter starts to spin, and the arm goes to position, lowers, plays for a second or two, lifts up, returns, then comes right back. All I can think of is giving it a major cleaning and seeing if that helps. I'll check the gears though. Thanks for the reply.

Link to post
Share on other sites

The thing is that it never even gets the chance to reach the middle. It has a mind of its own. As soon as it has power the platter starts to spin, and the arm goes to position, lowers, plays for a second or two, lifts up, returns, then comes right back. All I can think of is giving it a major cleaning and seeing if that helps. I'll check the gears though. Thanks for the reply.

 

I had this exact same turntable. Did they exact same thing, best bet is to take out the automatic mechanism. 

 

It could the cue lift. make sure it's tight enough, sometimes it may not seem like its that and it is. At first mine was that, then

 

eventually the auto feature completely went out and took it to a record shop, when I got it back he gave me all these spare parts saying I 

 

was better off.

 

found this in a AV forum, maybe this could help...

 

 

 

I removed the platter and mat because I was going to open it; but then underneath where the platter was I could see the whole mechanism, and work it out from there.

I needed to remove one thin metal rod joining the arm to a plastic 'trigger' on the inside; now it plays record until the end; and is sort-of still semi-automatic as the 'stop' button still works, and it brings the arm back to the beginning

Link to post
Share on other sites

It's usually a timing thing if it's all mechanical or some of them have sensors that get dirty but an SL-3300 I would expect to be timing related, it might have jumped or lost a tooth on one of the gears so it can't sync it's start or stop points.

 

The Vinyl Engine will have the service manual to download I expect which will probably help to show how to set the timing.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×

oh my wow GIF by ESPN Deportes

 

Please disable AdBlock OR sign-in in order to be able to access our website...

I Understand, I'll disable it for this website